summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBernhard Rosenkraenzer <bero@arklinux.org>2002-03-13 14:10:11 +0000
committerBernhard Rosenkraenzer <bero@arklinux.org>2002-03-13 14:10:11 +0000
commitf620c907368af50cc920699897bd88878591d011 (patch)
treeccaa89dd9f64c8b2c4d0dacf7caf43b07b889526 /src/Makefile.am
parent5c98abb55aeab9e78a505609092b10830a33128a (diff)
downloadgrep-f620c907368af50cc920699897bd88878591d011.tar.gz
Add fix for -i --color
* configure.in, src/Makefile.am: Don't duplicate code - make egrep and fgrep links to grep and set matcher based on application name, suggestion from Guillaume Cottenceau <gc@mandrakesoft.com> * src/grep.c: (prline) Add fix for -i --color from Jim Meyering <meyering@lucent.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0a02c49e..ae26e473 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,14 +5,12 @@ LN = ln
# We let configure figure out whether we need
# regex.c, strtoul.c, strtoull.c, and strtoumax.c.
-bin_PROGRAMS = grep egrep fgrep
-base_sources = grep.c grep.h \
+bin_PROGRAMS = grep
+grep_SOURCES = grep.c grep.h \
dfa.c dfa.h \
kwset.c kwset.h \
- search.c getpagesize.h system.h
-egrep_SOURCES = $(base_sources) egrepmat.c
-fgrep_SOURCES = $(base_sources) fgrepmat.c
-grep_SOURCES = $(base_sources) grepmat.c
+ search.c getpagesize.h system.h \
+ grepmat.c egrepmat.c fgrepmat.c
LDADD = @INTLLIBS@ ../lib/libgreputils.a
datadir = $(prefix)/@DATADIRNAME@
@@ -22,3 +20,7 @@ INCLUDES = -I../intl -I$(top_srcdir)/lib -DLOCALEDIR=\"$(localedir)\"
EXTRA_DIST = \
dosbuf.c \
vms_fab.c vms_fab.h
+
+install-local:
+ @LINK@ @bindir@/grep @bindir@/egrep
+ @LINK@ @bindir@/grep @bindir@/fgrep