summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2010-03-27 10:34:25 +0100
committerJim Meyering <meyering@redhat.com>2010-03-27 10:47:52 +0100
commitef5011d294a4dfc21a726b3103e9d277912cabaf (patch)
tree8c32ede7c8eaad7ae245e032400a2b6b9e410c18 /src/Makefile.am
parentfc24c8fc93f2ae97eac06f4e64e82b2e2f9e5ab1 (diff)
downloadgrep-ef5011d294a4dfc21a726b3103e9d277912cabaf.tar.gz
build: add -I$(top_builddir)/lib so we also find generated .h files
* src/Makefile.am (AM_CPPFLAGS): Rename from INCLUDES to avoid warning from automake -Wall. Add -I$(top_builddir)/lib, so we find generated .h files like getopt.h in a non-srcdir build.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 10516c9c..f0264b0b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,7 +37,7 @@ LDADD = libgrep.a ../lib/libgreputils.a $(LIBINTL) ../lib/libgreputils.a
grep_LDADD = $(LDADD) $(LIB_PCRE)
localedir = $(datadir)/locale
-INCLUDES = -I$(top_srcdir)/lib
+AM_CPPFLAGS = -I$(top_builddir)/lib -I$(top_srcdir)/lib
EXTRA_DIST = \
dosbuf.c \