summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlain Magloire <alainm@rcsm.ee.mcgill.ca>2001-02-08 17:01:32 +0000
committerAlain Magloire <alainm@rcsm.ee.mcgill.ca>2001-02-08 17:01:32 +0000
commite8dbb0dff11e6d78ca088858f09f13dd4953394c (patch)
tree9ff55613c34ca57a0e87ffa5a6eba379c1c06eff /src/Makefile.am
parenta4233d612029527527f41accd8d641d8e85749a0 (diff)
downloadgrep-e8dbb0dff11e6d78ca088858f09f13dd4953394c.tar.gz
Port to MING32
Port to Mingw32, based on suggestions from Christian Groessler <cpg@aladdin.de>. * src/isdir.c: New file, taken from fileutils. * src/Makefile.am (base_sources): Add isdir.c. * src/grep.c (grepfile): Use isdir instead of doing it inline. (grepdir): Suppress ancestor check if the directory's inode and device are both zero, as that occurs only on Mingw32 which doesn't support inode or device. * src/system.h (isdir): New decl. (is_EISDIR): Depend on HAVE_DIR_EACCES_BUG, not D_OK. Use isdir, not access. Problen noted by Gerald Stoller <gerald_stoller@hotmail.com> * src/grep.c (main): POSIX.2 says that -q overrides -l, which in turn overrides the other output options. Fix grep to behave that way.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0b43d4d7..22270e4b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,6 +15,7 @@ base_sources = grep.c grep.h \
savedir.c savedir.h \
xstrtol.c xstrtol.h xstrtoumax.c \
getopt.c getopt1.c getopt.h \
+ isdir.c \
search.c getpagesize.h system.h
egrep_SOURCES = $(base_sources) egrepmat.c
fgrep_SOURCES = $(base_sources) fgrepmat.c