summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2017-12-17 08:07:46 -0800
committerJim Meyering <meyering@fb.com>2017-12-17 08:23:30 -0800
commite3c0287a56e299d4df85cbfb32d58a5b731a696f (patch)
tree83d1b9bda506c26463e1c264f5bc2edbd74b96e0 /src/Makefile.am
parente6c447d02a406209c56d5ca92ce7660a31b2c114 (diff)
downloadgrep-e3c0287a56e299d4df85cbfb32d58a5b731a696f.tar.gz
build: link with -lsigsegv, when c-stack module requires it
* src/Makefile.am (grep_LDADD): Add $(LIBCSTACK). Otherwise, on at least Debian and Arch-based systems, linking would fail with diagnostics like these: c-stack.c:207: undefined reference to `stackoverflow_install_handler' c-stack.c:216: undefined reference to `sigsegv_install_handler' Reported by Jeremy Feusi.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 71c64f97..7a0cdef8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -43,7 +43,7 @@ LDADD = \
../lib/libgreputils.a $(LIBINTL) ../lib/libgreputils.a $(LIBICONV) \
$(LIBTHREAD)
-grep_LDADD = $(LDADD) $(PCRE_LIBS)
+grep_LDADD = $(LDADD) $(PCRE_LIBS) $(LIBCSTACK)
localedir = $(datadir)/locale
AM_CPPFLAGS = -I$(top_builddir)/lib -I$(top_srcdir)/lib