summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2010-03-29 08:33:11 +0200
committerJim Meyering <meyering@redhat.com>2010-03-29 08:33:11 +0200
commitc2b9a4fed35d198b8af8f38af877b8d1d52ec6f1 (patch)
tree137682a4b78159e18caab8cb48cb5b61d2282eae /src/Makefile.am
parent56f59c42bf09d4affabe4c89af4c55a1bc0775f6 (diff)
downloadgrep-c2b9a4fed35d198b8af8f38af877b8d1d52ec6f1.tar.gz
build: update after change in gnulib's lib-ignore module
* src/Makefile.am (AM_LDFLAGS): Define. Use gnulib's new $(IGNORE_UNUSED_LIBRARIES_CFLAGS).
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f0264b0b..73f3b189 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,6 +18,9 @@ LN = ln
AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
+# Tell the linker to omit references to unused shared libraries.
+AM_LDFLAGS = $(IGNORE_UNUSED_LIBRARIES_CFLAGS)
+
bin_PROGRAMS = grep egrep fgrep
grep_SOURCES = grep.c
egrep_SOURCES = egrep.c