summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2013-10-20 15:59:27 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2013-10-20 15:59:52 -0700
commitf9c758e1116c444d40493684f305190aafcc519d (patch)
tree6918f7df596ffe6a9080ac9581b214dd84c29766 /configure.ac
parent9350c3288150d75a5b5d4ca98cab18d338b8a00f (diff)
downloadgrep-f9c758e1116c444d40493684f305190aafcc519d.tar.gz
build: port shell pattern to Solaris 10
* configure.ac: Don't use unquoted '^' in a pattern, as this breaks 'configure' on Solaris 10, whose /bin/sh complains about it, which causes 'configure' to exit even before it finds a decent shell. Unix 7th edition shell accepted '^' as an alias for '|'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6ce72374..ab7d387d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,7 +43,7 @@ fn_grep () {
esac
case $pattern in
- [*[].^$\\*[]*]) dnl The outer brackets are for M4.
+ [*['].^$\*[']*]) dnl The outer brackets are for M4.
AC_MSG_ERROR([fn_grep: regular expressions not supported]) ;;
esac