summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2014-04-19 08:23:14 -0700
committerJim Meyering <meyering@fb.com>2014-04-19 09:07:34 -0700
commitd65dcf39f3d587027cccb6c7de6d7d70fb336e56 (patch)
tree104d0ba90381a7381d34bc04837bb1029f24b272 /configure.ac
parentee163d8f5ae541bdaab0f2d23826c7e4e275846b (diff)
downloadgrep-d65dcf39f3d587027cccb6c7de6d7d70fb336e56.tar.gz
build: reenable some compiler warning options
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 2 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 17a8920c..6a99c403 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,29 +114,12 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wlong-long" # C90 is anachronistic (lib/gethrxtime.h)
nw="$nw -Wc++-compat" # We don't care about C++ compilers
nw="$nw -Wundef" # Warns on '#if GNULIB_FOO' etc in gnulib
- nw="$nw -Wtraditional" # Warns on #elif which we use often
- nw="$nw -Wcast-qual" # Too many warnings for now
- nw="$nw -Wconversion" # Too many warnings for now
nw="$nw -Wsystem-headers" # Don't let system headers trigger warnings
- nw="$nw -Wsign-conversion" # Too many warnings for now
- nw="$nw -Wtraditional-conversion" # Too many warnings for now
- nw="$nw -Wunreachable-code" # Too many warnings for now
nw="$nw -Wpadded" # Our structs are not padded
- nw="$nw -Wredundant-decls" # openat.h declares e.g., mkdirat
- nw="$nw -Wlogical-op" # any use of fwrite provokes this
- nw="$nw -Wformat-nonliteral" # who.c and pinky.c strftime uses
nw="$nw -Wvla" # warnings in gettext.h
- nw="$nw -Wnested-externs" # use of XARGMATCH/verify_function__
- nw="$nw -Wswitch-enum" # Too many warnings for now
nw="$nw -Wswitch-default" # Too many warnings for now
- nw="$nw -Wstack-protector" # not worth working around
- # things I might fix soon:
- nw="$nw -Wfloat-equal" # sort.c, seq.c
- nw="$nw -Wmissing-format-attribute" # copy.c
- nw="$nw -Wunsafe-loop-optimizations" # a few src/*.c
- nw="$nw -Winline" # system.h's readdir_ignoring_dot_and_dotdot
- nw="$nw -Wstrict-overflow" # expr.c, pr.c, tr.c, factor.c
- # ?? -Wstrict-overflow
+ nw="$nw -Winline" # streq.h's streq4, streq6 and strcaseeq6
+ nw="$nw -Wstrict-overflow" # regexec.c
gl_MANYWARN_ALL_GCC([ws])
gl_MANYWARN_COMPLEMENT([ws], [$ws], [$nw])
@@ -166,12 +149,7 @@ if test "$gl_gcc_warnings" = yes; then
# We use a slightly smaller set of warning options for lib/.
# Remove the following and save the result in GNULIB_WARN_CFLAGS.
nw=
- #nw="$nw -Wuninitialized"
nw="$nw -Wunused-macros"
- #nw="$nw -Wmissing-prototypes"
- nw="$nw -Wold-style-definition"
- nw="$nw -Wcast-align"
- nw="$nw -Wunsuffixed-float-constants"
gl_WARN_ADD([-Wno-format-nonliteral])
gl_MANYWARN_COMPLEMENT([GNULIB_WARN_CFLAGS], [$WARN_CFLAGS], [$nw])
AC_SUBST([GNULIB_WARN_CFLAGS])