summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2014-04-24 01:10:01 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2014-04-24 01:10:20 -0700
commitc841bbb0fc18abaa20638a4f9b965ec075c23457 (patch)
tree09f05dacb5a3022bc4699cf5962a0d0e2adbf824 /configure.ac
parent8345ee380535825253744a0b22725171ab02479c (diff)
downloadgrep-c841bbb0fc18abaa20638a4f9b965ec075c23457.tar.gz
build: suppress unsafe-loop-optimizations warnings
I ran into one of these while trying out GCC 4.9.0's new -fsanitize=undefined option. The warning told me that GCC didn't do an unsafe optimization, but in 'grep' this is not typically a symptom of a programming error. * configure.ac (WERROR_CFLAGS): Suppress -Wunsafe-loop-optimizations.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6a99c403..c301ebe7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,6 +118,7 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wpadded" # Our structs are not padded
nw="$nw -Wvla" # warnings in gettext.h
nw="$nw -Wswitch-default" # Too many warnings for now
+ nw="$nw -Wunsafe-loop-optimizations" # OK to suppress unsafe optimizations
nw="$nw -Winline" # streq.h's streq4, streq6 and strcaseeq6
nw="$nw -Wstrict-overflow" # regexec.c