summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2014-06-17 12:09:16 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2014-06-17 12:09:37 -0700
commita5ef4c423bc583333cb465b72eff7b0dca7f68db (patch)
treee23eeee6b02f1afa5095768025448bb5f5cef4ea /configure.ac
parent824e15341240f3e2bff4e0cf9789edef9f80bacb (diff)
downloadgrep-a5ef4c423bc583333cb465b72eff7b0dca7f68db.tar.gz
build: avoid -Wstack-protector
This allows the use of --enable-gcc-warnings on Gentoo and Ubuntu. See: http://bugs.gnu.org/17793 * configure.ac (WERROR_CFLAGS): Avoid -Wstack-protector. This can be worked around, but the cure is worse than the disease.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ac29373..3315855d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,6 +117,7 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wsystem-headers" # Don't let system headers trigger warnings
nw="$nw -Wpadded" # Our structs are not padded
nw="$nw -Wvla" # warnings in gettext.h
+ nw="$nw -Wstack-protector" # generates false alarms for useful code
nw="$nw -Wswitch-default" # Too many warnings for now
nw="$nw -Wunsafe-loop-optimizations" # OK to suppress unsafe optimizations
nw="$nw -Winline" # streq.h's streq4, streq6 and strcaseeq6