summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2022-03-20 11:05:31 -0700
committerJim Meyering <meyering@fb.com>2022-03-20 13:23:58 -0700
commit9af9d51605fdedc18eaf24bcf693c812add29305 (patch)
tree627b17b3a5be9ff4f348912ac977eb50c46d9d29 /configure.ac
parent6e95551ad6a1e5591ea0d417c2d3eec1921e48b5 (diff)
downloadgrep-9af9d51605fdedc18eaf24bcf693c812add29305.tar.gz
build: avoid build failure on systems that must compile regexec.c
With --enable-gcc-warnings, compiling regexec.h would fail due to its use of a single variable-length array. * configure.ac: Add -Wvla to the list of disabled warnings and remove most of the others, that no longer need to be disabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 2 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 98d757a0..0a979824 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,18 +128,9 @@ if test $gl_gcc_warnings != no; then
nw=$ew
# This, $nw, is the list of warnings we disable.
- nw="$nw -Wdeclaration-after-statement" # too useful to forbid
- nw="$nw -Waggregate-return" # anachronistic
- nw="$nw -Wlong-long" # C90 is anachronistic (lib/gethrxtime.h)
- nw="$nw -Wc++-compat" # We don't care about C++ compilers
- nw="$nw -Wundef" # Warns on '#if GNULIB_FOO' etc in gnulib
+ nw="$nw -Wvla" # suppress a warning in regexec.h
nw="$nw -Wsystem-headers" # Don't let system headers trigger warnings
- nw="$nw -Wpadded" # Our structs are not padded
- nw="$nw -Wstack-protector" # generates false alarms for useful code
- nw="$nw -Wswitch-default" # Too many warnings for now
- nw="$nw -Wunsafe-loop-optimizations" # OK to suppress unsafe optimizations
- nw="$nw -Winline" # streq.h's streq4, streq6 and strcaseeq6
- nw="$nw -Wstrict-overflow" # regexec.c
+
gl_MANYWARN_ALL_GCC([ws])
gl_MANYWARN_COMPLEMENT([ws], [$ws], [$nw])