summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2019-01-20 22:19:54 -0800
committerJim Meyering <meyering@fb.com>2019-01-20 22:19:54 -0800
commit8df79c9fa79b6ce86fec0342f779125c85ff2f12 (patch)
tree4bfe323ad80a8f466958d5748ff0d911914a935a /configure.ac
parent06cec163ded9e6927ab6cc86bff6530302a107c6 (diff)
downloadgrep-8df79c9fa79b6ce86fec0342f779125c85ff2f12.tar.gz
build: ensure no VLA is used
Cause developer builds to fail for any use of a VLA. VLAs (variable length arrays) limit portability. * configure.ac (nw): Remove -Wvla from the list of disabled warnings, thus enabling the warning when configured with --enable-gcc-warnings. (GNULIB_NO_VLA) Define, disabling use of VLAs in gnulib. This commit is functionally equivalent to coreutils' v8.30-44-gd26dece5d.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1bbfc4f6..49998407 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,6 +94,10 @@ AC_TYPE_SIZE_T
AC_C_CONST
gl_INIT
+# Ensure VLAs are not used.
+# Note -Wvla is implicitly added by gl_MANYWARN_ALL_GCC
+AC_DEFINE([GNULIB_NO_VLA], [1], [Define to 1 to disable use of VLAs])
+
# The test suite needs to know if we have a working perl.
# FIXME: this is suboptimal. Ideally, we would be able to call gl_PERL
# with an ACTION-IF-NOT-FOUND argument ...
@@ -134,7 +138,6 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wundef" # Warns on '#if GNULIB_FOO' etc in gnulib
nw="$nw -Wsystem-headers" # Don't let system headers trigger warnings
nw="$nw -Wpadded" # Our structs are not padded
- nw="$nw -Wvla" # warnings in gettext.h
nw="$nw -Wstack-protector" # generates false alarms for useful code
nw="$nw -Wswitch-default" # Too many warnings for now
nw="$nw -Wunsafe-loop-optimizations" # OK to suppress unsafe optimizations