summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2023-04-01 21:01:01 -0700
committerJim Meyering <meyering@meta.com>2023-04-09 22:22:42 -0700
commit85e0e4fdd440ff41d12ce8f5fe7b30128a3cdb58 (patch)
tree83647d57e252db8e0b858303a2db8fa582564582 /configure.ac
parent88b2d37c0a975b736841f66c1b64401bb4d329f3 (diff)
downloadgrep-85e0e4fdd440ff41d12ce8f5fe7b30128a3cdb58.tar.gz
tests: add a known-failing glibc-infloop test
* tests/glibc-infloop: New file. Based on the command from Koen Claessen reported in https://bugs.gnu.org/62483 * configure.ac (USE_INCLUDED_REGEX): define. * tests/Makefile.am (TESTS): Add the file name * THANKS.in: Add name of reporter.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 528349c6..13ec9056 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,6 +212,7 @@ dnl then the installer should configure --with-included-regex.
AM_CONDITIONAL([USE_INCLUDED_REGEX], [test "$ac_use_included_regex" = yes])
if test "$ac_use_included_regex" = no; then
AC_MSG_WARN([Included lib/regex.c not used])
+ AC_DEFINE([USE_INCLUDED_REGEX], 1, [building with included regex code])
fi
gl_FUNC_PCRE