summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2022-03-20 17:18:13 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2022-03-22 08:19:16 -0700
commit70fc166b38933e73a45d5348634e626809a7bd32 (patch)
tree48005d1d4a06a2c430c83180987d008dd521822e /configure.ac
parentbc4241629c73b6a4006ec6176f927024cf15abc5 (diff)
downloadgrep-70fc166b38933e73a45d5348634e626809a7bd32.tar.gz
Pacify GCC 11.2.0
* configure.ac: Re-disable -Wstack-protector, to pacify GCC Ubuntu 11.2.0-7ubuntu2 x86-64 on knuth_morris_pratt and knuth_morris_pratt_multibyte.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 70cb128c..c85651c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,6 +131,7 @@ if test $gl_gcc_warnings != no; then
nw="$nw -Wvla" # suppress a warning in regexec.h
nw="$nw -Winline" # suppress warnings from streq.h's streq5
nw="$nw -Wsystem-headers" # Don't let system headers trigger warnings
+ nw="$nw -Wstack-protector" # generates false alarms for useful code
gl_MANYWARN_ALL_GCC([ws])
gl_MANYWARN_COMPLEMENT([ws], [$ws], [$nw])