summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2015-06-27 08:43:33 -0700
committerJim Meyering <meyering@fb.com>2016-07-24 14:59:53 -0700
commit4443fda05ace21b2a2da2d80b09313cc976afe59 (patch)
treee470de5f0b892cf50f71d5363656b7bd838b68f9 /configure.ac
parent5a9640cf2a36da39abbda98a4e9aa956d3951f9f (diff)
downloadgrep-4443fda05ace21b2a2da2d80b09313cc976afe59.tar.gz
tests: add coreutils' perl-driven test framework
* configure.ac: Set the AM_CONDITIONAL variable, HAVE_PERL. * tests/Coreutils.pm: New file. * tests/CuSkip.pm: New file. * tests/CuTmpdir.pm: New file. * tests/no-perl: New file. * tests/Makefile.am: Set up to use .pl tests: (TEST_EXTENSIONS, TESTSUITE_PERL, TESTSUITE_PERL_OPTIONS): Define. (SH_LOG_COMPILER, PL_LOG_COMPILER): Define. (EXTRA_DIST): Add the four new file names.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4de0f393..afb8cd28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,6 +94,13 @@ AC_TYPE_SIZE_T
AC_C_CONST
gl_INIT
+# The test suite needs to know if we have a working perl.
+# FIXME: this is suboptimal. Ideally, we would be able to call gl_PERL
+# with an ACTION-IF-NOT-FOUND argument ...
+cu_have_perl=yes
+case $PERL in *"/missing "*) cu_have_perl=no;; esac
+AM_CONDITIONAL([HAVE_PERL], [test $cu_have_perl = yes])
+
AC_ARG_ENABLE([gcc-warnings],
[AS_HELP_STRING([--enable-gcc-warnings],
[turn on lots of GCC warnings (for developers)])],