summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2022-03-20 13:37:44 -0700
committerJim Meyering <meyering@fb.com>2022-03-20 13:37:44 -0700
commit16b3c2f9f3a3e2deb70af74ba0914fd19d9c1085 (patch)
treefdfdeb769f27ad1da22cf8eaede22a72f791c450 /configure.ac
parent269795f3b8d5fc6ee5bc8e575aa2e96557b0b949 (diff)
downloadgrep-16b3c2f9f3a3e2deb70af74ba0914fd19d9c1085.tar.gz
build: Re-disable -Winline
* configure.ac: Re-disable -Winline. It is still needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0a979824..70cb128c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,9 +129,9 @@ if test $gl_gcc_warnings != no; then
nw=$ew
# This, $nw, is the list of warnings we disable.
nw="$nw -Wvla" # suppress a warning in regexec.h
+ nw="$nw -Winline" # suppress warnings from streq.h's streq5
nw="$nw -Wsystem-headers" # Don't let system headers trigger warnings
-
gl_MANYWARN_ALL_GCC([ws])
gl_MANYWARN_COMPLEMENT([ws], [$ws], [$nw])
for w in $ws; do