summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2011-10-13 13:41:22 +0200
committerJim Meyering <meyering@redhat.com>2011-10-14 09:13:36 +0200
commite88a270d07c56567a042899256abc5c4804fc9d8 (patch)
tree12adeb8294a03bf17079c47787bc700fd5e78526 /Makefile.am
parentfb205d2ab461b45188d55e70957574af8533d58e (diff)
downloadgrep-e88a270d07c56567a042899256abc5c4804fc9d8.tar.gz
distcheck: ensure dist-hook fails if syntax-check fails
* Makefile.am (run-syntax-check): Fix logic, to ensure that the recipe of this target returns a non-zero exit status if "make syntax-check" fails.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a13f2625..e9005d72 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,7 +31,7 @@ EXTRA_DIST = \
# Run syntax-check rules before creating a distribution tarball.
.PHONY: run-syntax-check
run-syntax-check:
- $(AM_V_GEN)test -d .git && $(MAKE) syntax-check || :
+ $(AM_V_GEN)test ! -d .git || $(MAKE) syntax-check
# Arrange so that .tarball-version appears only in the distribution
# tarball, and never in a checked-out repository.