summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-11-29 10:36:08 +0100
committerJim Meyering <meyering@redhat.com>2009-11-30 16:54:58 +0100
commitbaea70f27f3634a4ebe90728929181803968805b (patch)
treed29a15d5625b2474a7b20baf304c5499c930adec /Makefile.am
parente632b4015a25e57e53f843ef6322688f9b5e1e31 (diff)
downloadgrep-baea70f27f3634a4ebe90728929181803968805b.tar.gz
maint: generate ChangeLog from git logs
* Makefile.am (dist-hook, gen-ChangeLog): New rules. * bootstrap.conf (gnulib_modules): Add gitlog-to-changelog. Ensure that ChangeLog exists. * ChangeLog-2009: Rename from ChangeLog * ChangeLog: Remove file. * .gitignore: Add ChangeLog.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d33a835..769a1106 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# Process this file with automake to create Makefile.in
-#
+#
# Copyright 1997, 1998, 2005, 2006, 2007, 2008, 2009 Free Software
# Foundation, Inc.
#
@@ -53,3 +53,18 @@ cvs-clean:
fi ; \
done; \
done
+
+# Arrange so that .tarball-version appears only in the distribution
+# tarball, and never in a checked-out repository.
+dist-hook: gen-ChangeLog
+ $(AM_V_GEN)echo $(VERSION) > $(distdir)/.tarball-version
+
+gen_start_date = 2009-11-27
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ $(AM_V_GEN)if test -d .git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ --since=$(gen_start_date) > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi