summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlain Magloire <alainm@rcsm.ee.mcgill.ca>1999-08-17 19:08:31 +0000
committerAlain Magloire <alainm@rcsm.ee.mcgill.ca>1999-08-17 19:08:31 +0000
commitaf6099c2bd6f927a56d5624f87c5ecb7640a776b (patch)
tree477156cb6b2f5c072bc02c492e79f47e94c6d824 /Makefile.am
parentee6d5e12230df022ad4454650a7c7fee1adb827f (diff)
downloadgrep-af6099c2bd6f927a56d5624f87c5ecb7640a776b.tar.gz
add support for largefiles
add support for largefiles Upgrade large-file support to the version used in tar and textutils. * Makefile.am (ACLOCAL_AMFLAGS): Define to be empty. (M4DIR, ACINCLUDE_INPUTS): New macros. ($(srcdir)/acinclude.m4): New rule. * configure.in (AC_CANONICAL_HOST, AM_C_PROTOTYPES): Add. (AC_SYS_LARGEFILE): Renamed from AC_LFS, for compatibility with what should appear in the next autoconf release. * m4/largefile.m4: Renamed from m4/lfs.m4. * src/ansi2knr.1, src/ansi2knr.c, config.guess, config.sub: New files. config.guess and config.sub ar needed by the new AC_SYS_LARGEFILE. ansi2knr is needed by AM_C_PROTOTYPES, which in turn is needed by the new AC_SYS_LARGEFILE.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c335f0bf..a65e4f2e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,20 @@
## Process this file with automake to create Makefile.in
AUTOMAKE_OPTIONS = no-dependencies
-ACLOCAL_AMFLAGS = --acdir=m4
SUBDIRS = intl po doc src tests djgpp m4 vms bootstrap
EXTRA_DIST = TODO README PATCHES-AC PATCHES-AM
+
+# We should be able to just define `ACLOCAL_AMFLAGS = --acdir=m4',
+# but this runs afoul of a bug in automake 1.
+# The following hack works around this bug by creating acinclude.m4 manually.
+ACLOCAL_AMFLAGS =
+M4DIR = $(srcdir)/m4
+ACINCLUDE_INPUTS = $(M4DIR)/djgpp.m4 $(M4DIR)/dosfile.m4 \
+ $(M4DIR)/envsep.m4 $(M4DIR)/gettext.m4 $(M4DIR)/glibc.m4 \
+ $(M4DIR)/header.m4 $(M4DIR)/init.m4 $(M4DIR)/install.m4 \
+ $(M4DIR)/isc-posix.m4 $(M4DIR)/largefile.m4 $(M4DIR)/lcmessage.m4 \
+ $(M4DIR)/missing.m4 $(M4DIR)/progtest.m4 $(M4DIR)/regex.m4 \
+ $(M4DIR)/sanity.m4
+$(srcdir)/acinclude.m4 : $(ACINCLUDE_INPUTS)
+ cat $(ACINCLUDE_INPUTS) >$(srcdir)/acinclude.m4