summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 659d3dc..4bd5460 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,11 +4,11 @@
# make sure we're interpreted by some minimal autoconf
AC_PREREQ(2.57)
-AC_INIT(google-perftools, 1.10, opensource@google.com)
+AC_INIT(gperftools, 2.0, google-perftools@googlegroups.com)
# Update this value for every release! (A:B:C will map to foo.so.(A-C).C.B)
# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
-TCMALLOC_SO_VERSION=4:0:0
-PROFILER_SO_VERSION=2:1:2
+TCMALLOC_SO_VERSION=5:0:1
+PROFILER_SO_VERSION=3:0:3
AC_SUBST(TCMALLOC_SO_VERSION)
AC_SUBST(PROFILER_SO_VERSION)
@@ -166,7 +166,7 @@ AC_CHECK_DECLS([cfree,
#include <malloc.h>])
if test "$ac_cv_type_struct_mallinfo" = yes; then
- AC_SUBST(ac_cv_have_struct_mallinfo, 1) # google/tcmalloc.h needs this
+ AC_SUBST(ac_cv_have_struct_mallinfo, 1) # gperftools/tcmalloc.h needs this
else
AC_SUBST(ac_cv_have_struct_mallinfo, 0)
fi
@@ -362,10 +362,10 @@ AC_DEFINE(PERFTOOLS_DLL_DECL,,
# the end result is if config.h is #included twice, its #undefs get
# evaluated twice, but all the ones in mingw.h/etc only get evaluated
# once, potentially causing trouble. c.f.
-# http://code.google.com/p/google-perftools/issues/detail?id=246
+# http://code.google.com/p/gperftools/issues/detail?id=246
AH_TOP([
-#ifndef GOOGLE_PERFTOOLS_CONFIG_H_
-#define GOOGLE_PERFTOOLS_CONFIG_H_
+#ifndef GPERFTOOLS_CONFIG_H_
+#define GPERFTOOLS_CONFIG_H_
])
AH_VERBATIM([PTHREADS_CRASHES_IF_RUN_TOO_EARLY],
@@ -387,7 +387,7 @@ AH_BOTTOM([
#include "windows/mingw.h"
#endif
-#endif /* #ifndef GOOGLE_PERFTOOLS_CONFIG_H_ */
+#endif /* #ifndef GPERFTOOLS_CONFIG_H_ */
])
AM_CONDITIONAL(MINGW, expr $host : '.*-mingw' >/dev/null 2>&1)
AM_CONDITIONAL(OSX, expr $host : '.*-apple-darwin.*' >/dev/null 2>&1)
@@ -416,5 +416,6 @@ AM_CONDITIONAL(WITH_STACK_TRACE, test "$enable_cpu_profiler" = yes -o \
"$enable_heap_checker" = yes)
# Write generated configuration file
-AC_CONFIG_FILES([Makefile src/google/tcmalloc.h src/windows/google/tcmalloc.h])
+AC_CONFIG_FILES([Makefile
+ src/gperftools/tcmalloc.h src/windows/gperftools/tcmalloc.h])
AC_OUTPUT