summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2009-03-06 20:05:23 +0000
committerzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2009-03-06 20:05:23 +0000
commitb0fe69fcbfaa44ae05f6f2429d9c4bbb326b5ea5 (patch)
treece6c72890e27b3215259bedcf7ddb9e28eff4544 /Makefile.am
parentc85c0c20322a1f36113cf4d6282908e16ca32669 (diff)
downloadgoogletest-b0fe69fcbfaa44ae05f6f2429d9c4bbb326b5ea5.tar.gz
Implements --gtest_throw_on_failure for using gtest with other testing frameworks.
git-svn-id: http://googletest.googlecode.com/svn/trunk@199 861a406c-534a-0410-8894-cb66d6ee9925
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2a465dd..fc182d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,7 +13,6 @@ EXTRA_DIST = \
scons/SConscript \
scripts/fuse_gtest_files.py \
scripts/gen_gtest_pred_impl.py \
- src/gtest-all.cc \
test/gtest_all_test.cc
# MSVC project files
@@ -263,6 +262,13 @@ check_PROGRAMS += test/gtest-test-part_test
test_gtest_test_part_test_SOURCES = test/gtest-test-part_test.cc
test_gtest_test_part_test_LDADD = lib/libgtest_main.la
+TESTS += test/gtest_throw_on_failure_ex_test
+check_PROGRAMS += test/gtest_throw_on_failure_ex_test
+test_gtest_throw_on_failure_ex_test_SOURCES = \
+ test/gtest_throw_on_failure_ex_test.cc \
+ src/gtest-all.cc
+test_gtest_throw_on_failure_ex_test_CXXFLAGS = $(AM_CXXFLAGS) -fexceptions
+
TESTS += test/gtest-typed-test_test
check_PROGRAMS += test/gtest-typed-test_test
test_gtest_typed_test_test_SOURCES = test/gtest-typed-test_test.cc \
@@ -327,6 +333,14 @@ EXTRA_DIST += test/gtest_output_test_golden_lin.txt \
test/gtest_output_test_golden_win.txt
TESTS += test/gtest_output_test.py
+check_PROGRAMS += test/gtest_throw_on_failure_test_
+test_gtest_throw_on_failure_test__SOURCES = \
+ test/gtest_throw_on_failure_test_.cc \
+ src/gtest-all.cc
+test_gtest_throw_on_failure_test__CXXFLAGS = $(AM_CXXFLAGS) -fno-exceptions
+check_SCRIPTS += test/gtest_throw_on_failure_test.py
+TESTS += test/gtest_throw_on_failure_test.py
+
check_PROGRAMS += test/gtest_uninitialized_test_
test_gtest_uninitialized_test__SOURCES = test/gtest_uninitialized_test_.cc
test_gtest_uninitialized_test__LDADD = lib/libgtest.la