summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2009-11-24 20:19:45 +0000
committerzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2009-11-24 20:19:45 +0000
commit89f3c263a8bb78a6a7ba2078852c2d3f1cc5ed86 (patch)
tree38f5aae68b5e0a48991fdcbd7729647c9213fdfa /Makefile.am
parentc23fd197eec5a5bd471cc19ebadcd248dfcad16c (diff)
downloadgoogletest-89f3c263a8bb78a6a7ba2078852c2d3f1cc5ed86.tar.gz
Refactors run_tests.py s.t. it can be shared by gmock (by Vlad Losev); Fixes a warning in gtest-tuple_test.cc on Cygwin (by Vlad Losev).
git-svn-id: http://googletest.googlecode.com/svn/trunk@344 861a406c-534a-0410-8894-cb66d6ee9925
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ec3e5ee..14880b8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,6 +11,7 @@ EXTRA_DIST = \
include/gtest/internal/gtest-type-util.h.pump \
include/gtest/internal/gtest-param-util-generated.h.pump \
make/Makefile \
+ run_tests.py \
scons/SConscript \
scons/SConstruct \
scons/SConstruct.common \
@@ -432,6 +433,10 @@ test_gtest_xml_output_unittest__LDADD = lib/libgtest.la
check_SCRIPTS += test/gtest_xml_output_unittest.py
TESTS += test/gtest_xml_output_unittest.py
+check_SCRIPTS += test/run_tests_util.py \
+ test/run_tests_util_test.py
+TESTS += test/run_tests_util_test.py
+
# TODO(wan@google.com): make the build script compile and run the
# negative-compilation tests. (The test/gtest_nc* files are unfinished
# implementation of tests for verifying that certain kinds of misuse