summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 8aa72f443b..4e579c2d9d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -453,13 +453,15 @@ AM_CONDITIONAL(ENABLE_OLDGNUTLS_INTEROP, test "$enable_oldgnutls_interop" != "no
# check for libev - used in full test suite
AC_LIB_HAVE_LINKFLAGS(ev,, [#include <ev.h>], [ev_run(0,0);])
if test "$ac_cv_libev" = yes; then
- AC_SUBST([LIBEV_LIBS], [$LIBEV])
-elif test "$full_test_suite" = yes;then
- AC_MSG_ERROR([[***
-*** libev4 was not found.
-***]])
+ AC_SUBST([LIBEV_LIBS], [$LIBEV])
+else
+ AC_MSG_WARN([[
+*** tests/suite/eagain.sh is disabled due to missing libev ***
+]])
fi
+AM_CONDITIONAL(HAVE_LIBEV, test "$ac_cv_libev" = "yes")
+
dnl GCC warnings to enable
AC_ARG_ENABLE([gcc-warnings],