summaryrefslogtreecommitdiff
path: root/tests/suite/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-10-07 15:25:31 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-10-11 13:59:41 +0200
commit2b518f533126a3098a08999e8d62825787a8212c (patch)
treeabffbc31e594c7d8a3a7358e294b3d6080f79d4d /tests/suite/Makefile.am
parent206414e55543e34ece06337132767f1887f569d7 (diff)
downloadgnutls-2b518f533126a3098a08999e8d62825787a8212c.tar.gz
tests: added checks for the decoding of various PKCS#7 structures
Diffstat (limited to 'tests/suite/Makefile.am')
-rw-r--r--tests/suite/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/suite/Makefile.am b/tests/suite/Makefile.am
index ea5d2d2cbc..6ef7456071 100644
--- a/tests/suite/Makefile.am
+++ b/tests/suite/Makefile.am
@@ -30,7 +30,9 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/tests/suite/ecore/src/include \
-I$(top_srcdir)/tests/suite/ecore/src/lib
-EXTRA_DIST = crl/long.crl crl/long.pem
+EXTRA_DIST = crl/long.crl crl/long.pem data/test1.cat data/test2.cat \
+ data/test1.cat.data data/test2.cat.data \
+ data/test1.cat.out data/test2.cat.out data/ca.pem
check_PROGRAMS = rng
AM_LDFLAGS = -no-install
@@ -87,7 +89,7 @@ EXTRA_DIST += testcompat-main-polarssl testcompat-main-openssl testcompat-common
testpkcs11.pkcs15 testpkcs11.softhsm testpkcs11.sc-hsm
nodist_check_SCRIPTS = testsrn.sh chain.sh invalid-cert.sh \
testpkcs11.sh testrng.sh testcompat-polarssl.sh testcompat-openssl.sh \
- testrandom.sh
+ testrandom.sh pkcs7-cat
if ENABLE_PKCS11
nodist_check_SCRIPTS += testpkcs11.sh crl-test