summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2015-08-24 12:00:10 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2015-08-24 13:13:39 +0200
commitd35813ffac53aa7c1c7106d7dd74ac90db79f7fa (patch)
tree8f11c4a1af16897e159fc98bcb4bd3e56c8056e0 /lib/Makefile.am
parentc862a1b94ea4212fc24f3a800bc18dbc235fde03 (diff)
downloadgnutls-d35813ffac53aa7c1c7106d7dd74ac90db79f7fa.tar.gz
Added simpler verification functions for clients
The major use-case for the TLS protocol is verification of PKIX certificates. However, certificate verification support while is similar for almost all projects it requires around 100 lines of code (a callback) to be duplicated to all applications. That patch set gets rid of the callback and simplifies certificate verification support, by introducing a very simple API; one that would accept the session and the hostname only. Resolves #27
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 9e60733fbc..6c455b0d5b 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -75,7 +75,7 @@ COBJECTS = range.c record.c compress.c debug.c cipher.c \
random.c crypto-api.c privkey.c pcert.c pubkey.c locks.c dtls.c \
system_override.c crypto-backend.c verify-tofu.c pin.c tpm.c fips.c \
safe-memfuncs.c inet_pton.c atfork.c atfork.h \
- system-keys.h urls.c urls.h prf.c
+ system-keys.h urls.c urls.h prf.c auto-verify.c
if WINDOWS
COBJECTS += system-keys-win.c