summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorAlfredo Pironti <alfredo@pironti.eu>2013-01-22 20:05:08 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-01-23 20:31:17 +0100
commit4968dd090ecf9c88a105a2c805cf97638bcca75d (patch)
treec30b8e7516dfa5dffe16912abd4e9f2217258307 /lib/Makefile.am
parente5b8398af0361b7803e7c97cf43a45044bd68414 (diff)
downloadgnutls-4968dd090ecf9c88a105a2c805cf97638bcca75d.tar.gz
GnuTLS Length Hiding patch.
- Remove random padding; use minimal padding with legacy interface - With new interface, use LH when possible, that is in CBC mode or with the new padding extension - Rename priority to "NEW_PADDING" - gnutls-cli: add command line switch --ranges using LH when possible. - Update documentation Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 8edd15dda0..816b3c5271 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -61,7 +61,8 @@ SRP_COBJECTS = gnutls_srp.c
PSK_COBJECTS = gnutls_psk.c
-COBJECTS = gnutls_record.c gnutls_compress.c debug.c gnutls_cipher.c \
+COBJECTS = gnutls_range.c gnutls_record.c \
+ gnutls_compress.c debug.c gnutls_cipher.c \
gnutls_mbuffers.c gnutls_buffers.c gnutls_handshake.c \
gnutls_num.c gnutls_errors.c gnutls_dh.c gnutls_kx.c \
gnutls_priority.c gnutls_hash_int.c gnutls_cipher_int.c \