summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid King <amigadave@amigadave.com>2015-10-20 12:55:14 +0200
committerDavid King <amigadave@amigadave.com>2015-10-20 12:55:14 +0200
commitea6d834044c014b29a2b6c25e3fdb236d91dcd11 (patch)
tree9963206b8cc00de79d15c0ffc723de446f40b0e7 /Makefile.am
parent161c9c4de6e9a410f84fcdcaf6e497253cef7575 (diff)
downloadyelp-ea6d834044c014b29a2b6c25e3fdb236d91dcd11.tar.gz
Convert data/domains subdir to non-recursive make
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b29acb4e..b89de832 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -126,6 +126,21 @@ dist_scalableicon_DATA = \
data/icons/hicolor/scalable/status/yelp-page-video-symbolic.svg \
data/icons/hicolor/scalable/status/yelp-page-symbolic.svg
+domaindir = $(datadir)/yelp-xsl/xslt/common/domains
+
+data/domains/yelp.pot: data/domains/yelp.xml.in
+ $(ITSTOOL) -o "$@" "$^"
+
+data/domains/yelp.xml: data/domains/yelp.xml.in
+ $(AM_V_GEN) ( \
+ for lang in $(ALL_LINGUAS); do \
+ msgfmt -o "$$lang.mo" "$(top_srcdir)/po/$$lang.po" || exit 1; \
+ done; \
+ $(ITSTOOL) -o "$@" -j "$^" $(foreach ll,$(ALL_LINGUAS),$(ll).mo); \
+ rm $(foreach ll,$(ALL_LINGUAS),$(ll).mo))
+
+domain_DATA = data/domains/yelp.xml
+
xsldir = $(pkgdatadir)/xslt
xsl_DATA = \
@@ -138,7 +153,10 @@ xsl_DATA = \
dist_noinst_DATA = \
$(desktop_in_files) \
$(gsettings_SCHEMAS) \
- $(yelp_headers)
+ $(yelp_headers) \
+ data/domains/yelp.pot \
+ data/domains/yelp.xml.in \
+ data/domains/yelp.xml
dist_noinst_SCRIPTS = \
autogen.sh