summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMartyn Russell <martyn@lanedo.com>2014-07-18 16:05:58 +0100
committerMartyn Russell <martyn@lanedo.com>2014-07-21 10:45:50 +0100
commit82503863417bc686d50e029382c8db2e3ec7317c (patch)
treed08bc702ba5ec7f07859020cbe2fd903e0510743 /tests/Makefile.am
parent1f1cc76a7054d52e2c4766ce248fc963305e5f67 (diff)
downloadtracker-82503863417bc686d50e029382c8db2e3ec7317c.tar.gz
build: Large update to configure.ac including new --enable-minimal option
Updates include: 1. Now you can use --enable-minimal, and only tracker-store is built and command line utilities, everything else is disabled. 2. All ./configure arguments have been updated to use $enableval and $withval. This fixes cases where the --disable-* variant is used. This has also fixed some cases where the AC_ARG_ENABLE or AC_ARG_WITH 'if-not-given' was used incorrectly. 3. There is now a --enable-tracker-extract (default is enabled), now it can be disabled. 4. There is now a --enable-tracker-writeback (default is enabled), now it can be disabled. 5. Summary now reflects what is built more concisely and is much smaller when using --enable-minimal. 6. After running autoscan, ./configure now has more checks for PROGS, HEADERS and FUNCS that are being used. 7. AC_USE_SYSTEM_EXTENSIONS is now used adding C extensions where available (like _GNU_SOURCE).
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am20
1 files changed, 13 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2c948be53..048b64798 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,17 +4,23 @@ SUBDIRS = \
common \
gvdb \
libtracker-common \
- libtracker-extract \
libtracker-miner \
libtracker-data \
libtracker-sparql \
- tracker-steroids \
- tracker-writeback
-
-if DIST_FUNCTIONAL_TESTS
-SUBDIRS += functional-tests
-endif
+ tracker-steroids
if HAVE_TRACKER_FTS
SUBDIRS += libtracker-fts
endif
+
+if HAVE_TRACKER_EXTRACT
+SUBDIRS += libtracker-extract
+endif
+
+if HAVE_TRACKER_WRITEBACK
+SUBDIRS += tracker-writeback
+endif
+
+if DIST_FUNCTIONAL_TESTS
+SUBDIRS += functional-tests
+endif