summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorQuentin Glidic <sardemff7+git@sardemff7.net>2017-12-10 11:17:41 +0100
committerSam Thursfield <sam@afuera.me.uk>2017-12-16 15:04:32 +0000
commit19443a0f71d9bd9793b40f7be4c4879e88de7ecc (patch)
tree0ea6da9ceff79bf69052ae6ed40bbbc51832296b /meson.build
parentfe77c4dbf6d7e3abe145a979f697b227a83cdb6e (diff)
downloadtracker-19443a0f71d9bd9793b40f7be4c4879e88de7ecc.tar.gz
meson: Allow to build with non-GNU libc
https://bugzilla.gnome.org/show_bug.cgi?id=791432 Signed-off-by: Quentin Glidic <sardemff7+git@sardemff7.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8a159af50..e293215fd 100644
--- a/meson.build
+++ b/meson.build
@@ -31,7 +31,7 @@ libxml2 = dependency('libxml-2.0', version: '> 2.6')
network_manager = dependency('libnm', required: false)
sqlite = dependency('sqlite3', version: '>' + sqlite_required)
-libmath = cc.find_library('m')
+libmath = cc.find_library('m', required: false)
# FIXME: here we work around a quirk todo with Meson and Vala: the 'uuid'
# pkg-config component corresponds to 'libuuid.vapi', but Meson assumes that