summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2021-06-23 14:22:23 +0200
committerBastien Nocera <hadess@hadess.net>2021-06-23 16:56:29 +0200
commitd215a84ebe05557828c24fe5e7ab400e2b41a328 (patch)
tree045226a12c6134866d62df1c44fdd6911ff39bf1 /meson.build
parent80160f0dd9dbd551e6466d7c664362c56500d249 (diff)
downloadtotem-pl-parser-d215a84ebe05557828c24fe5e7ab400e2b41a328.tar.gz
all: Remove quvi dependency
libquvi has been dead upstream for a number of years, and recent lua changes made it drop from distributions. It wasn't used in our official distribution channel, through Flathub.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build28
1 files changed, 4 insertions, 24 deletions
diff --git a/meson.build b/meson.build
index 0aa06cf..0a34d1d 100644
--- a/meson.build
+++ b/meson.build
@@ -32,7 +32,6 @@ plparse_libversion = '@0@.@1@.@2@'.format(plparse_soversion, plparse_lt_age, pl
# Requirements
glib_req = '>= 2.56.0'
gio_req = '>= 2.24.0'
-quvi_req = '>= 0.9.1'
archive_req = '>= 3.0'
# Dependencies
@@ -152,23 +151,6 @@ if enable_uchardet != 'no'
endif
endif
-# quvi dependency
-enable_quvi = get_option('enable-quvi')
-have_quvi = false
-pkgconf.set('QUVI', '')
-if enable_quvi != 'no'
- quvi_dep = dependency('libquvi-0.9', version: quvi_req, required: false)
- if enable_quvi == 'yes' and not quvi_dep.found()
- error('Quvi support requested but not available.')
- endif
- if quvi_dep.found()
- pkgconf.set('QUVI', 'libquvi-0.9')
- cdata.set('HAVE_QUVI', true,
- description: 'libquvi available in the system')
- have_quvi = true
- endif
-endif
-
# libarchive dependency
enable_libarchive = get_option('enable-libarchive')
have_libarchive = false
@@ -251,12 +233,10 @@ message('''
Configuration summary:
- Quvi video link parsing : @0@
- ISO detection with libarchive : @1@
- AmazonAMZ decoding with libgcrypt : @2@
- uchardet encoding detection : @3@
-'''.format(have_quvi.to_string('yes', 'no'),
- have_libarchive.to_string('yes', 'no'),
+ ISO detection with libarchive : @0@
+ AmazonAMZ decoding with libgcrypt : @1@
+ uchardet encoding detection : @2@
+'''.format(have_libarchive.to_string('yes', 'no'),
have_libgcrypt.to_string('yes', 'no'),
have_uchardet.to_string('yes', 'no')))