summaryrefslogtreecommitdiff
path: root/build/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'build/Makefile.am')
-rw-r--r--build/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/build/Makefile.am b/build/Makefile.am
index f1cc400..73a8b1b 100644
--- a/build/Makefile.am
+++ b/build/Makefile.am
@@ -6,10 +6,10 @@ VALGRIND_CONTRIB = \
$(NULL)
SUPPRESSIONS = \
- gcrypt.supp \
- glib.supp \
- pthread.supp \
- unknown.supp \
+ $(srcdir)/gcrypt.supp \
+ $(srcdir)/glib.supp \
+ $(srcdir)/pthread.supp \
+ $(srcdir)/unknown.supp \
$(NULL)
valgrind-suppressions: $(SUPPRESSIONS)
@@ -19,4 +19,8 @@ EXTRA_DIST = \
valgrind \
$(SUPPRESSIONS)
+CLEANFILES = \
+ valgrind-suppressions \
+ $(NULL)
+
all-local: valgrind-suppressions