summaryrefslogtreecommitdiff
path: root/rest/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'rest/meson.build')
-rw-r--r--rest/meson.build22
1 files changed, 1 insertions, 21 deletions
diff --git a/rest/meson.build b/rest/meson.build
index 545221b..0a16c36 100644
--- a/rest/meson.build
+++ b/rest/meson.build
@@ -17,8 +17,6 @@ librest_sources = [
'rest-xml-node.c',
'rest-xml-parser.c',
'rest-main.c',
- 'oauth-proxy.c',
- 'oauth-proxy-call.c',
'sha1.c',
'rest-oauth2-proxy.c',
@@ -31,8 +29,6 @@ librest_sources = [
]
librest_headers = [
- 'oauth-proxy-call.h',
- 'oauth-proxy.h',
'rest-param.h',
'rest-params.h',
'rest-proxy-call.h',
@@ -119,20 +115,4 @@ librest_dep = declare_dependency(
dependencies: librest_deps,
)
-meson.override_dependency('rest-1.0', librest_dep)
-
-# Test suite
-test_runner_c_args = [
- '-DBUILD_TESTS',
-]
-
-test_runner_bin = executable('test-runner',
- [ 'test-runner.c', librest_sources ],
- dependencies: librest_deps,
- c_args: test_runner_c_args,
- include_directories: config_h_inc,
-)
-
-test('test-runner', test_runner_bin,
- suite: 'rest',
-)
+meson.override_dependency('rest-1.0', librest_dep) \ No newline at end of file