summaryrefslogtreecommitdiff
path: root/rest-extras/meson.build
diff options
context:
space:
mode:
authorGünther Wagner <info@gunibert.de>2021-12-28 16:46:10 +0100
committerGünther Wagner <info@gunibert.de>2022-01-12 19:47:12 +0100
commitb6b20dae6f06a3badc6be09532d735a375b62e19 (patch)
tree3dd25cd3bea315d841076547dc61ecbeae4b2e05 /rest-extras/meson.build
parentb71c932a64e4060c2cbce05aac040e1c6d7dc43f (diff)
downloadlibrest-b6b20dae6f06a3badc6be09532d735a375b62e19.tar.gz
params: reworked to boxed and list
RestParams was implemented as HashTable. Limitations are that it did not preserved the order of individual parameters aswell as duplicates aren't allowed. Reworked it to a GList and introduced reference counting and a boxed type.
Diffstat (limited to 'rest-extras/meson.build')
-rw-r--r--rest-extras/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/rest-extras/meson.build b/rest-extras/meson.build
index 1ad9ee1..cf14ee8 100644
--- a/rest-extras/meson.build
+++ b/rest-extras/meson.build
@@ -49,9 +49,12 @@ if get_option('introspection')
librest_extras_gir = gnome.generate_gir(librest_extras_lib,
sources: librest_extras_sources + librest_extras_headers,
namespace: 'RestExtras',
+ symbol_prefix: 'rest_extras',
+ identifier_prefix: 'RestExtras',
nsversion: librest_api_version,
includes: [ 'GObject-2.0', 'Gio-2.0', 'Soup-@0@'.format(libsoup_api_version), librest_gir[0] ],
extra_args: [ '--accept-unprefixed' ],
+ dependencies: librest_extras_deps,
install: true,
)
endif