summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw@src.gnome.org>2019-07-24 16:54:35 +0800
committerTing-Wei Lan <lantw@src.gnome.org>2019-07-24 16:54:35 +0800
commit8c95ba82813fab1777d920544c179d1a2c10156a (patch)
tree46fbed952a93cfb97ee99d4954e7555e77265db9 /configure.ac
parent4b92a08cd23038cb8699b3e743dc3f5d3fef3b8a (diff)
downloadlibgnomekbd-8c95ba82813fab1777d920544c179d1a2c10156a.tar.gz
build: Allow building with gettext ≥ 0.20
The use of AM_GNU_GETTEXT_VERSION in configure.ac instructs autopoint to copy po/Makefile.in.in from the exact gettext version. It is fine if the version of gettext installed on the system has the same minor version number with the requested version, but it fails if you have a newer version of gettext because of the mismatch between autoconf macros and Makefile.in.in. *** error: gettext infrastructure mismatch: using a Makefile.in.in from gettext version 0.19 but the autoconf macros are from gettext version 0.20 Instead of specifying the exact version with AM_GNU_GETTEXT_VERSION, we can use AM_GNU_GETTEXT_REQUIRE_VERSION to ask autopoint to simply use the gettext version installed on the system to prevent the mismatch. This also bumps the version requirement on gettext to 0.19.6 because AM_GNU_GETTEXT_REQUIRE_VERSION was added in this version.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index beb5ee1..7b3972f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,7 +37,9 @@ AM_PROG_LIBTOOL
# ****
# i18n
# ****
-AM_GNU_GETTEXT_VERSION([0.19.4])
+# FIXME: Remove AM_GNU_GETTEXT_VERSION once autoreconf supports REQUIRE_VERSION
+AM_GNU_GETTEXT_VERSION([0.19.6])
+AM_GNU_GETTEXT_REQUIRE_VERSION([0.19.6])
AM_GNU_GETTEXT([external])
GETTEXT_PACKAGE=libgnomekbd