summaryrefslogtreecommitdiff
path: root/tests/gtest/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/gtest/meson.build')
-rw-r--r--tests/gtest/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/gtest/meson.build b/tests/gtest/meson.build
new file mode 100644
index 0000000..33637d7
--- /dev/null
+++ b/tests/gtest/meson.build
@@ -0,0 +1,12 @@
+foreach program : ['context', 'bugs']
+ test(
+ program,
+ executable(
+ 'test-' + program,
+ 'test-@0@.c'.format (program),
+ dependencies : gupnp,
+ c_args : '-DDATA_PATH="@0@/data"'.format(meson.current_source_dir())
+ ),
+ is_parallel : false
+ )
+endforeach