summaryrefslogtreecommitdiff
path: root/subprojects/guul/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'subprojects/guul/meson.build')
-rw-r--r--subprojects/guul/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/subprojects/guul/meson.build b/subprojects/guul/meson.build
new file mode 100644
index 0000000..aea40c4
--- /dev/null
+++ b/subprojects/guul/meson.build
@@ -0,0 +1,33 @@
+project('guul', 'c', version : '0.1')
+
+cc = meson.get_compiler('c')
+dependencies = [
+ dependency('glib-2.0')
+]
+args = []
+
+if host_machine.system() == 'windows'
+ args += '-DGUUL_PLATFORM_WINDOWS'
+ dependencies += cc.find_library('rpcrt4')
+elif host_machine.system() == 'darwin'
+ args += '-DGUUL_PLATFORM_OSX'
+else
+ if not cc.has_function('uuid_to_string')
+ dependencies += dependency('uuid')
+ args += '-DGUUL_PLATFORM_GENERIC'
+ else
+ args += '-DGUUL_PLATFORM_BSD'
+ endif
+endif
+
+guul_lib = static_library(
+ 'guul',
+ sources : 'guul.c',
+ c_args : args,
+ dependencies : dependencies
+)
+
+guul = declare_dependency (
+ link_with : guul_lib,
+ include_directories: include_directories('.')
+)