summaryrefslogtreecommitdiff
path: root/doc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
new file mode 100644
index 0000000..cfaec18
--- /dev/null
+++ b/doc/meson.build
@@ -0,0 +1,27 @@
+entities = configuration_data()
+entities.set('VERSION', meson.project_version())
+configure_file(input: 'version.xml.in',
+ output: 'version.xml', configuration:
+ entities)
+
+gnome.gtkdoc('gupnp',
+ main_xml : 'gupnp-docs.xml',
+ src_dir : [join_paths(meson.source_root(), 'libgupnp'),
+ join_paths(meson.build_root(), 'libgupnp')],
+ dependencies : libgupnp,
+ ignore_headers : [
+ 'gena-protocol.h',
+ 'xml-util.h',
+ 'gvalue-util.h',
+ 'http-headers.h',
+ 'gupnp-context-private.h',
+ 'gupnp-linux-context-manager.h',
+ 'gupnp-network-manager.h',
+ 'gupnp-unix-context-manager.h',
+ 'gupnp-device-info-private.h',
+ 'gupnp-error-private.h',
+ 'gupnp-resource-factory-private.h',
+ 'gupnp-service-introspection-private.h',
+ 'gupnp-types-private.h'
+ ],
+ install : true)