summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2022-01-03 11:07:59 +0100
committerJens Georg <mail@jensge.org>2022-01-03 19:10:51 +0100
commitd2ad83d588759d005c7a3bae87f7523666e9a733 (patch)
tree35de8ceeb48fe817dfc03c5026150b7c35af1c8f /meson.build
parent79a2cb24cd0079e9a025809d11dce13edce68bdd (diff)
downloadgupnp-d2ad83d588759d005c7a3bae87f7523666e9a733.tar.gz
docs: Use gi-docgen instead of gtk-doc
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8dcda0c..5f7eebd 100644
--- a/meson.build
+++ b/meson.build
@@ -44,6 +44,12 @@ dependencies = [
subdir('libgupnp')
subdir('tests')
subdir('tools')
+
+gidocgen_dep = dependency('gi-docgen', version: '>= 2021.1',
+ fallback: ['gi-docgen', 'dummy_dep'],
+ required: get_option('gtk_doc') and get_option('introspection')
+ )
+
subdir('doc')
if get_option('vapi') and get_option('introspection')