summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2021-06-19 18:20:14 +0200
committerJens Georg <mail@jensge.org>2021-06-19 18:37:24 +0200
commit98b2f54fa6138c8975d5595e63b3d128e1d27072 (patch)
tree391478189d4b585e245a8539524319694f960f93 /meson.build
parentb4683272380fc3e28a8605e33a9da952a2e57a33 (diff)
downloadgupnp-98b2f54fa6138c8975d5595e63b3d128e1d27072.tar.gz
build: Move config.h to private folder
This is necessary to use it nicely in a subproject, see https://mesonbuild.com/Wrap-best-practices-and-tips.html#do-not-put-configh-in-external-search-path
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index f31e4be..0b8f298 100644
--- a/meson.build
+++ b/meson.build
@@ -18,9 +18,7 @@ add_project_arguments(cc.get_supported_arguments('-Werror=deprecated-declaration
conf.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSION_' + glib_version.underscorify())
conf.set('GLIB_VERSION_MAX_ALLOWED', 'GLIB_VERSION_' + glib_version.underscorify())
-config_h = configure_file(output : 'config.h', configuration : conf)
-add_project_arguments('-DHAVE_CONFIG_H=1', language : 'c')
-
+subdir('internal')
guul = subproject('guul', default_options : ['default_library=static'])
gssdp_dep = dependency('gssdp-1.2', version : '>= 1.2.3', default_options: ['sniffer=false'])
@@ -34,7 +32,7 @@ dependencies = [
dependency('gobject-2.0', version : '>= ' + glib_version),
dependency('libsoup-2.4', version : '>= 2.48.0'),
gssdp_dep,
- dependency('libxml-2.0')
+ dependency('libxml-2.0'),
]
subdir('libgupnp')