summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2021-08-07 09:41:50 +0200
committerJens Georg <mail@jensge.org>2021-11-21 12:05:07 +0100
commit8ce9544b3c3ebc0385a7c5942c09b734dc7e4ee2 (patch)
tree3ce88c131bd363d96ccc2deee39ab6e124d4534b /meson.build
parentb77d9734101b4dbccd8cfb56a04e0ce52d119ec1 (diff)
downloadgupnp-8ce9544b3c3ebc0385a7c5942c09b734dc7e4ee2.tar.gz
all: Initial port to libsoup3 API
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index fbd244e..8dcda0c 100644
--- a/meson.build
+++ b/meson.build
@@ -19,10 +19,10 @@ conf.set('HAVE_NETLINK', netlink_available)
conf.set('HAVE_IFADDRS_H', ifaddrs_available)
conf.set('HAVE_LINUX_WIRELESS_H', cc.has_header('linux/wireless.h'))
-glib_version = '2.66'
+glib_version = '2.69'
add_project_arguments(cc.get_supported_arguments('-Werror=deprecated-declarations'), language: 'c')
-conf.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSION_' + glib_version.underscorify())
-conf.set('GLIB_VERSION_MAX_ALLOWED', 'GLIB_VERSION_' + glib_version.underscorify())
+conf.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSION_2_70'.format(glib_version.underscorify()))
+conf.set('GLIB_VERSION_MAX_ALLOWED', 'GLIB_VERSION_2_70'.format(glib_version.underscorify()))
subdir('internal')
guul = subproject('guul', default_options : ['default_library=static'])
@@ -36,7 +36,7 @@ dependencies = [
dependency('gio-2.0', version : '>= ' + glib_version),
dependency('gmodule-2.0', version : '>= ' + glib_version),
dependency('gobject-2.0', version : '>= ' + glib_version),
- dependency('libsoup-2.4', version : '>= 2.48.0'),
+ dependency('libsoup-3.0', version : '>= 2.99.0'),
gssdp_dep,
dependency('libxml-2.0'),
]