summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2021-05-30 11:49:08 +0200
committerJens Georg <mail@jensge.org>2021-06-09 23:55:54 +0200
commit433d1c1cb9fb4773a3ccda412b782d8b70c372b6 (patch)
tree5f458bee4c1a01a83a08edddd3b13b227c9e0009 /meson.build
parent859f5dbf69b9624dd2fb332a8f983530ae040a64 (diff)
downloadgupnp-433d1c1cb9fb4773a3ccda412b782d8b70c372b6.tar.gz
tests: Use g_unix_signal_add
We were using illegal functions in the Unix signal handler For windows, keep on using sigint for now. Perhaps moving to SetCtrlHandler might be an option: https://docs.microsoft.com/en-us/windows/console/registering-a-control-handler-function
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 443ccc3..48667b8 100644
--- a/meson.build
+++ b/meson.build
@@ -25,6 +25,8 @@ guul = subproject('guul', default_options : ['default_library=static'])
gssdp_dep = dependency('gssdp-1.2', version : '>= 1.2.3', default_options: ['sniffer=false'])
+gio_unix = dependency('gio-unix-2.0', version: '>= 2.44', required: host_machine.system() != 'windows')
+
dependencies = [
dependency('glib-2.0', version : '>= ' + glib_version),
dependency('gio-2.0', version : '>= ' + glib_version),