summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2021-10-24 16:49:12 +0200
committerJens Georg <mail@jensge.org>2021-10-27 11:20:55 +0200
commit3065367fc2d5cc23f66f13d030f25d3ad15f31c0 (patch)
tree5e89ce4e5dc3a783b103b3e1e8f47299296dd340 /meson.build
parent0175039d71cd72ee8c9b718e752d3fa81851359c (diff)
downloadgupnp-3065367fc2d5cc23f66f13d030f25d3ad15f31c0.tar.gz
all: Bump API version
Reset ABI version, also bump project version
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 18 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3790bcf..0eb0cc7 100644
--- a/meson.build
+++ b/meson.build
@@ -1,9 +1,15 @@
-project('gupnp', 'c', version : '1.4.0', meson_version : '>= 0.54.0')
+project('gupnp', 'c', version : '1.5.0', meson_version : '>= 0.54.0')
gnome = import('gnome')
pkg = import('pkgconfig')
cc = meson.get_compiler('c')
+GUPNP_API_VERSION='1.6'
+GUPNP_API_NAME='gupnp-@0@'.format(GUPNP_API_VERSION)
+api_config = configuration_data()
+api_config.set('GUPNP_API_VERSION', GUPNP_API_VERSION)
+api_config.set('GUPNP_API_NAME', GUPNP_API_NAME)
+
netlink_available = cc.has_header('linux/rtnetlink.h')
ifaddrs_available = cc.has_header('ifaddrs.h')
@@ -47,3 +53,14 @@ endif
if get_option('examples')
subdir('examples')
endif
+
+summary(
+ {
+ 'Version': meson.project_version(),
+ 'API Version' : GUPNP_API_VERSION,
+ 'Library version': version,
+ 'Darwin version': darwin_versions
+ },
+ section: 'Versioning'
+)
+