summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2009-06-26 17:04:28 +0200
committerZeeshan Ali (Khattak) <zeeshanak@gnome.org>2010-10-10 22:24:24 +0300
commit492e526d4b1d933d1441dd759d8b1bdbe72c0cc3 (patch)
treef815bbe670c1a238060a27d3c11b403f857caf39 /configure.ac
parent36f851a7a0287f3bc7ab55f2fe7937e08402fff6 (diff)
downloadgssdp-492e526d4b1d933d1441dd759d8b1bdbe72c0cc3.tar.gz
Make it compile on mingw
Add headers and casts necessary to silence mingw. Additionaly "interface" is a macro on Windows which leads to weird compiler errors; renaming the variables was unavoidable To make libtool generate DLLs on windows the linker flag -no-undefined needs to be passed; otherwise libtool will only create static libraries.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4691e76..cd23d0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,6 +63,18 @@ if test "x$enable_debug" = "xyes"; then
fi
GOBJECT_INTROSPECTION_CHECK([0.6.4])
+dnl Check for Win32
+AC_MSG_CHECKING([for Win32])
+case "$host" in
+ *-*-mingw*)
+ os_win32=yes
+ ;;
+ *)
+ os_win32=no
+ ;;
+esac
+AC_MSG_RESULT([$os_win32])
+AM_CONDITIONAL(OS_WIN32, [test $os_win32 = yes])
GTK_DOC_CHECK([1.0])