summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..605ad56
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,21 @@
+# meson.build
+#
+# Author: Victor Toso <me@victortoso.com>
+#
+# Copyright (C) 2018 Grilo Project
+
+tests = [
+ 'autoptr',
+ 'lib-net',
+ 'registry',
+]
+
+foreach t: tests
+ source = t + '.c'
+ exe = executable(t,
+ source,
+ install: false,
+ link_with: [libgrl, libgrlnet],
+ dependencies: [libgrl_dep, libgrlnet_dep])
+ test(t, exe, timeout:10)
+endforeach