summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 0 insertions, 11 deletions
diff --git a/meson.build b/meson.build
index 3bfb619..bdc4332 100644
--- a/meson.build
+++ b/meson.build
@@ -34,8 +34,6 @@ gtk_req_version = '>= 3.12.0'
libhandy_req_version = '>= 0.90.0'
mathlib_dep = cc.find_library('m', required: false)
-x11_dep = dependency('x11', required: get_option ('x11'))
-xext_dep = dependency('xext', required: get_option ('x11'))
glib_dep = dependency('glib-2.0', version: glib_req_version)
gtk_dep = dependency('gtk+-3.0', version: gtk_req_version)
libhandy_dep = dependency('libhandy-1', version: libhandy_req_version)
@@ -45,15 +43,6 @@ config_h = configuration_data()
config_h.set_quoted('VERSION', meson.project_version())
config_h.set_quoted('GETTEXT_PACKAGE', meson.project_name())
-has_x11 = x11_dep.found() and xext_dep.found()
-if has_x11
- config_h.set('HAVE_X11', 1)
-
- if cc.has_header('X11/extensions/shape.h')
- config_h.set('HAVE_X11_EXTENSIONS_SHAPE_H', 1)
- endif
-endif
-
configure_file(output: 'config.h', configuration: config_h)
root_inc = include_directories('.')