summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCosimo Cecchi <cosimoc@gnome.org>2011-09-27 22:30:30 -0400
committerCosimo Cecchi <cosimoc@gnome.org>2011-09-28 10:20:34 -0400
commit1f285a5c74d43ae1f458f0b0f4dce206acbd4a0d (patch)
tree101447bde2a2308a734c458bfedda8c1e1813f50 /Makefile.am
parentec30107a8f4bd7afa07426dc0ffff05c497731a2 (diff)
downloadgnome-font-viewer-1f285a5c74d43ae1f458f0b0f4dce206acbd4a0d.tar.gz
Update for module split
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am59
1 files changed, 1 insertions, 58 deletions
diff --git a/Makefile.am b/Makefile.am
index ed8d380..dd6709f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,58 +1 @@
-
-INCLUDES = \
- $(GIO_CFLAGS) \
- $(GTK_CFLAGS) \
- -DDIRECTORY_DIR=\"$(directorydir)\" \
- -DGNOMELOCALEDIR=\"$(datadir)/locale\"
-
-bin_PROGRAMS = \
- gnome-thumbnail-font \
- gnome-font-viewer
-
-ftstream_SOURCES = \
- ftstream-vfs.h \
- ftstream-vfs.c
-
-gnome_thumbnail_font_LDADD = \
- $(GIO_LIBS) \
- $(GTK_LIBS)
-
-gnome_thumbnail_font_SOURCES = \
- $(ftstream_SOURCES) \
- font-thumbnailer.c \
- totem-resources.c \
- totem-resources.h
-
-gnome_font_viewer_LDADD = \
- $(XFT_LIBS) \
- $(GIO_LIBS) \
- $(GTK_LIBS)
-
-gnome_font_viewer_SOURCES = \
- $(ftstream_SOURCES) \
- font-view.c
-
-desktopdir = $(datadir)/applications
-desktop_in_files = gnome-font-viewer.desktop.in
-desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
-
-thumbnailerdir = $(datadir)/thumbnailers
-thumbnailer_DATA = gnome-font-viewer.thumbnailer
-
-install-desktop-database: install-desktopDATA
- update-desktop-database $(DESTDIR)$(desktopdir)
-
-uninstall-local:
- rm -f $(DESTDIR)$(desktopdir)/mimeinfo.cache
-
-@INTLTOOL_DESKTOP_RULE@
-@INTLTOOL_DIRECTORY_RULE@
-
-CLEANFILES = $(desktop_in_files) $(desktop_DATA) \
- $(directory_DATA)
-
-EXTRA_DIST = \
- gnome-font-viewer.thumbnailer \
- gnome-font-viewer.desktop.in.in
-
--include $(top_srcdir)/git.mk
+SUBDIRS = src po