summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSergio Costas <raster@rastersoft.com>2022-01-29 12:40:16 +0100
committerMichael Catanzaro <mcatanzaro@gnome.org>2022-04-11 20:54:51 +0000
commit0da1fcac914ad4c67f016bda7864c4b153cbfbaa (patch)
tree2b338e343ae3845d4f5f69e65e0eea9dc5739dc8 /meson.build
parentf305beff5cd391ac6c57cc4a23f029699777574d (diff)
downloadgnome-desktop-0da1fcac914ad4c67f016bda7864c4b153cbfbaa.tar.gz
Add GCancellable and GError to the thumbnail API
The methods generate_thumbnail(), save_thumbnail and create_failed_thumbnail from the class gnome_desktop_thumbnail_factory offers neither a GError nor a GCancellable options. For synchronous operations this is not a true problem, but for asynchronous operations both are a good idea. This MR adds those parameters to the method.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 8333d946..6435acc4 100644
--- a/meson.build
+++ b/meson.build
@@ -17,11 +17,11 @@ project('gnome-desktop', 'c',
# to 0. When bumping the second version, set the third one to zero.
#
# A lot easier than libtool, right?
-libversion = '1.3.0'
+libversion = '2.0.0'
soversion = libversion.split('.')[0]
# Compatibility versions for libgnome-desktop-3
-compat_libversion = '19.4.0'
+compat_libversion = '20.0.0'
compat_soversion = compat_libversion.split('.')[0]
gdk_pixbuf_req = '>= 2.36.5'