summaryrefslogtreecommitdiff
path: root/tests/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/common/meson.build')
-rw-r--r--tests/common/meson.build29
1 files changed, 14 insertions, 15 deletions
diff --git a/tests/common/meson.build b/tests/common/meson.build
index 4d982f029..055009249 100644
--- a/tests/common/meson.build
+++ b/tests/common/meson.build
@@ -1,23 +1,22 @@
-test_unit = 'test-hostname'
-
-sources = files(
- test_unit + '.c'
-)
+test_units = [
+ 'test-hostname',
+ # 'test-time-entry', # FIXME
+]
cflags = [
'-DTEST_SRCDIR="@0@"'.format(meson.current_source_dir()),
'-DTEST_TOPSRCDIR="@0@"'.format(meson.source_root())
]
-exe = executable(
- test_unit,
- sources,
- include_directories : [ top_inc, common_inc ],
- dependencies : common_deps + [libwidgets_dep],
- c_args : cflags,
-)
-
-test(test_unit, exe)
-
+foreach unit: test_units
+ exe = executable(
+ unit,
+ unit + '.c',
+ include_directories : [ top_inc, common_inc ],
+ dependencies : common_deps + [libwidgets_dep],
+ c_args : cflags,
+ )
+ test(unit, exe)
+endforeach