summaryrefslogtreecommitdiff
path: root/archiver/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'archiver/Makefile.am')
-rw-r--r--archiver/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/archiver/Makefile.am b/archiver/Makefile.am
index 88cc4a921..83872e450 100644
--- a/archiver/Makefile.am
+++ b/archiver/Makefile.am
@@ -9,18 +9,23 @@ INCLUDES = \
-DLOCATION_DIR=\""$(datadir)/hcm/default"\" \
$(XML_CFLAGS)
-bin_PROGRAMS = archiver
+bin_PROGRAMS = helix-archiver
+lib_LIBRARIES = libhelix_archiver.a
-archiver_SOURCES = \
- main.c \
+libhelix_archiver_a_SOURCES = \
archive.c archive.h \
location.c location.h \
config-log.c config-log.h \
backend-list.c backend-list.h \
util.c util.h
-archiver_LDADD = \
+helix_archiver_SOURCES = \
+ main.c
+
+helix_archiver_LDADD = \
$(GNOME_LIBDIR) \
$(GNOMEUI_LIBS) \
$(INTLLIBS) \
- $(GNOME_XML_LIB)
+ $(GNOME_XML_LIB) \
+ helix_archiver.a
+