summaryrefslogtreecommitdiff
path: root/archiver/Makefile.am
diff options
context:
space:
mode:
authorBradford Hovinen <hovinen@helixcode.com>2000-12-19 14:51:19 +0000
committerBradford Hovinen (Gdict maintainer) <hovinen@src.gnome.org>2000-12-19 14:51:19 +0000
commitaec5f9b2f1f018bda3b0344de8b1e8f6191f6418 (patch)
tree51b90d9a71236efddd32ded6919207474cffe3ad /archiver/Makefile.am
parentf089da28865399e612072845aced7e40ec078dd7 (diff)
downloadgnome-control-center-aec5f9b2f1f018bda3b0344de8b1e8f6191f6418.tar.gz
Changed name of archiver to helix-archiver (lib_LIBRARIES): Added
2000-12-19 Bradford Hovinen <hovinen@helixcode.com> * Makefile.am (bin_PROGRAMS): Changed name of archiver to helix-archiver (lib_LIBRARIES): Added libhelix_archiver.a (helix_archiver_SOURCES): Moved archiver core to libhelix_archiver_a_SOURCES (helix_archiver_LDADD): Added helix_archiver.a * Added default backend lists
Diffstat (limited to 'archiver/Makefile.am')
-rw-r--r--archiver/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/archiver/Makefile.am b/archiver/Makefile.am
index 88cc4a921..83872e450 100644
--- a/archiver/Makefile.am
+++ b/archiver/Makefile.am
@@ -9,18 +9,23 @@ INCLUDES = \
-DLOCATION_DIR=\""$(datadir)/hcm/default"\" \
$(XML_CFLAGS)
-bin_PROGRAMS = archiver
+bin_PROGRAMS = helix-archiver
+lib_LIBRARIES = libhelix_archiver.a
-archiver_SOURCES = \
- main.c \
+libhelix_archiver_a_SOURCES = \
archive.c archive.h \
location.c location.h \
config-log.c config-log.h \
backend-list.c backend-list.h \
util.c util.h
-archiver_LDADD = \
+helix_archiver_SOURCES = \
+ main.c
+
+helix_archiver_LDADD = \
$(GNOME_LIBDIR) \
$(GNOMEUI_LIBS) \
$(INTLLIBS) \
- $(GNOME_XML_LIB)
+ $(GNOME_XML_LIB) \
+ helix_archiver.a
+