summaryrefslogtreecommitdiff
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2011-11-07 17:51:54 +0000
committerBastien Nocera <hadess@hadess.net>2011-11-07 18:03:14 +0000
commit27c45abda3294239c7881a2ad878d9d1443f099a (patch)
tree3b6b78fc97ea5c555c39bc66c990c6dec5eed2ce /shell/Makefile.am
parentacd1d3c6df9fee02d4e9961bd522a4def300242b (diff)
downloadgnome-control-center-27c45abda3294239c7881a2ad878d9d1443f099a.tar.gz
shell: Merge libgnome-control-center into main binary
This fixes problems with the CcEditableEntry type not being registered and causing the printers and user-accounts panels not to work. As we do not need to work on Windows, we do not need to split out the library.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index a3a11af4b..5912e0c60 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -1,6 +1,5 @@
INCLUDES = \
-I$(top_srcdir) \
- -I$(top_srcdir)/libgnome-control-center \
$(SHELL_CFLAGS)
bin_PROGRAMS = gnome-control-center
@@ -28,10 +27,15 @@ gnome_control_center_SOURCES = \
cc-shell-item-view.h \
cc-shell-model.c \
cc-shell-model.h \
+ cc-editable-entry.c \
+ cc-editable-entry.h \
+ cc-panel.c \
+ cc-panel.h \
+ cc-shell.c \
+ cc-shell.h \
$(MARSHAL_FILES)
gnome_control_center_LDADD = \
- $(top_builddir)/libgnome-control-center/libgnome-control-center.la \
$(SHELL_LIBS)
gnome_control_center_LDFLAGS = -export-dynamic